Jump to content
PRIYATOSH Sinha

R12.1.3 | HTTP abruptly stopped after running for ~8-9 hours

Recommended Posts

Hi Team -

Apache services are getting abruptly stopped in EBS R12.1.3 on RHEL 7.  On investigating we found that the httpd.pid file is missing from $INST_TOP/pids/10.1.3/Apache ,

Apache process gets orphaned and KILL -9 <Apache PID> also doesn't work .

--Server :  /var/log/messages  Output--

kernel: INFO: task httpd:<HTTPD PID > blocked for more than 120 seconds.

--HTTP_Server.log---

$INST_TOP/ora/10.1.3/Apache/Apache/bin/apachectl hardstop: httpd (no pid file) not running

Any thoughts or inputs is really appreciable.

 

Share this post


Link to post
Share on other sites

Hi Priyatosh,

Thanks for writing to us!

We think the underlying filesystem is NFS. If yes, then this is expected. What is the nature of underlying filesystem? In R12.1, inst_top should be in local storage.

Thanks and Regards,

Alekhya

Share this post


Link to post
Share on other sites

Hi Alekhya -

As a temporary workaround, we have changed the PID Location to a local Mount point and we are not facing any issue after that .

Yes , FS is a NFS one and this issue started after server team upgraded the Clusterware software.

Thx

 

 

Share this post


Link to post
Share on other sites

Hi Priyatosh,

This is a known issue and you have to move it. The recommendation is to move entire inst top. If that is not feasible, Then move pid and lock file directory to local fs.

Thanks and Regards,

Alekhya

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×